<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="google-site-verification" content="tyilNUfx3od05lrD0motWTN-_BiYn9yyjHR0nC2L0yc" />
<meta charset="UTF-8">
<meta name="temp" content="for VaultPress">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://beachmetro.com/xmlrpc.php">

	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-20693582-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20693582-1');
</script>
	
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Optimized by SG Optimizer plugin version - 5.7.20 -->
	<!-- This site is optimized with the Yoast SEO plugin v16.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Deja Views: A look back at Greenwood Raceway in 1988 &ndash; Beach Metro Community News</title>
	<link rel="canonical" href="https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Deja Views: A look back at Greenwood Raceway in 1988 &ndash; Beach Metro Community News" />
	<meta property="og:description" content="By DAVID VAN DYKE Recently, my son Michael and I spent an hour walking around Woodbine Park looking for the two trees depicted in the photo above. Really, how much does a tree grow in just more than 32 years? The tree on the right had been felled and we did find its stump to [&hellip;]" />
	<meta property="og:url" content="https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/" />
	<meta property="og:site_name" content="Beach Metro Community News" />
	<meta property="article:publisher" content="https://www.facebook.com/BeachMetroNews/" />
	<meta property="article:published_time" content="2021-04-25T09:00:59+00:00" />
	<meta property="article:modified_time" content="2021-04-23T14:37:06+00:00" />
	<meta property="og:image" content="https://beachmetro.com/wp-content/uploads/2021/04/web-Deja-Views-woodbine1988.jpg" />
	<meta property="og:image:width" content="648" />
	<meta property="og:image:height" content="424" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@beachmetronews" />
	<meta name="twitter:site" content="@beachmetronews" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Al Shackleton">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="1 minute">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://beachmetro.com/#website","url":"https://beachmetro.com/","name":"Beach Metro Community News","description":"The Beach&#039;s source for news since 1972","potentialAction":[{"@type":"SearchAction","target":"https://beachmetro.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/#primaryimage","inLanguage":"en-US","url":"https://beachmetro.com/wp-content/uploads/2021/04/web-Deja-Views-woodbine1988.jpg","contentUrl":"https://beachmetro.com/wp-content/uploads/2021/04/web-Deja-Views-woodbine1988.jpg","width":648,"height":424,"caption":"Laura Harrison 14:10 (1 hour ago) to me Hi His name is John Leslie Harrison. He moved to the Beaches Lions Centennial Apartments at 50 Norway Ave in 1987 after his wife died and lived there until 2012. He mentioned he walked three kilometres a day and took his camera on various walks around the area. A tree was planted in his memory at Woodbine park near the children\u2019s play area."},{"@type":"WebPage","@id":"https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/#webpage","url":"https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/","name":"Deja Views: A look back at Greenwood Raceway in 1988 &ndash; Beach Metro Community News","isPartOf":{"@id":"https://beachmetro.com/#website"},"primaryImageOfPage":{"@id":"https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/#primaryimage"},"datePublished":"2021-04-25T09:00:59+00:00","dateModified":"2021-04-23T14:37:06+00:00","author":{"@id":"https://beachmetro.com/#/schema/person/4372a1b32b9e9c89ec0ff2bddfbd309f"},"breadcrumb":{"@id":"https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/"]}]},{"@type":"BreadcrumbList","@id":"https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://beachmetro.com/","url":"https://beachmetro.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/","url":"https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/","name":"Deja Views: A look back at Greenwood Raceway in 1988"}}]},{"@type":"Person","@id":"https://beachmetro.com/#/schema/person/4372a1b32b9e9c89ec0ff2bddfbd309f","name":"Al Shackleton","image":{"@type":"ImageObject","@id":"https://beachmetro.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/078166f04c86f0bb03e3c76dc8836c6a?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/078166f04c86f0bb03e3c76dc8836c6a?s=96&d=identicon&r=g","caption":"Al Shackleton"},"sameAs":["http://beachmetro.com"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Beach Metro Community News &raquo; Feed" href="https://beachmetro.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Beach Metro Community News &raquo; Comments Feed" href="https://beachmetro.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/beachmetro.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://beachmetro.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='csbwf_sidebar_style-css'  href='https://beachmetro.com/wp-content/plugins/custom-share-buttons-with-floating-sidebar/css/csbwfs.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://beachmetro.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='dw-megamenu-front-end-style-css'  href='https://beachmetro.com/wp-content/plugins/dw-mega-menu/assets/css/dw-megamenu.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='zurlcustom-style-css'  href='https://beachmetro.com/wp-content/plugins/z-url-preview/zurlplugin.css?ver=5.7.1' type='text/css' media='all' />
<style id='zurlcustom-style-inline-css' type='text/css'>
#at_zurlpreview img {
				width: 100%;
				max-width:100%;
 			}
</style>
<link rel='stylesheet' id='dw-focus-main-css'  href='https://beachmetro.com/wp-content/themes/dw-focus/assets/css/dw-focus.min.css?ver=1.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-style-css'  href='https://beachmetro.com/wp-content/themes/dw-focus/style.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-print-css'  href='https://beachmetro.com/wp-content/themes/dw-focus/assets/css/print.css?ver=1.2.6' type='text/css' media='print' />
<link rel='stylesheet' id='options_typography_Roboto+Slab-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab' type='text/css' media='all' />
<link rel='stylesheet' id='options_typography_Oswald-css'  href='https://fonts.googleapis.com/css?family=Oswald' type='text/css' media='all' />
<link rel='stylesheet' id='options_typography_PT+Sans-css'  href='https://fonts.googleapis.com/css?family=PT+Sans' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://beachmetro.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.13' type='text/css' media='all' />
<style id='tablepress-default-inline-css' type='text/css'>
.tablepress-id-1{width:360px}.tablepress-id-1 td{font-size:12px;color:#000}.tablepress-id-3 td{font-size:11px;color:#000}.tablepress-id-3 a{font-size:14px}.tablepress-id-3 a:hover{color:#2c4577;text-decoration:none}.tablepress-id-5 td{font-size:11px;color:#000}.tablepress-id-5 a{font-size:14px}.tablepress-id-5 a:hover{color:#2c4577;text-decoration:none}.tablepress-id-6 td{line-height:155%;font-size:14px}
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://beachmetro.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://beachmetro.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://beachmetro.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://beachmetro.com/wp-content/themes/dw-focus/assets/js/modernizr.min.js?ver=1.2.6' id='modernizr-js'></script>
<script type='text/javascript' src='https://beachmetro.com/wp-content/themes/dw-focus/assets/js/jquery-mobile.min.js?ver=1.3.2' id='jquery-mobile-js'></script>
<link rel="https://api.w.org/" href="https://beachmetro.com/wp-json/" /><link rel="alternate" type="application/json" href="https://beachmetro.com/wp-json/wp/v2/posts/40907" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://beachmetro.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://beachmetro.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://beachmetro.com/?p=40907' />
<link rel="alternate" type="application/json+oembed" href="https://beachmetro.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeachmetro.com%2F2021%2F04%2F25%2Fdeja-views-a-look-back-at-greenwood-raceway-in-1988%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://beachmetro.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbeachmetro.com%2F2021%2F04%2F25%2Fdeja-views-a-look-back-at-greenwood-raceway-in-1988%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" sizes="32x32" />
<link rel="icon" href="https://beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" />
<meta name="msapplication-TileImage" content="https://beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" />
<link rel="stylesheet" href="https://beachmetro.com/wp-content/plugins/oiopub-direct/images/style/output.css?260" type="text/css" />
</head>

<body class="post-template-default single single-post postid-40907 single-format-standard layout-boxed sidebar-right">
<div id="page" class="hfeed site">
	<header class="site-header">
		<div class="container">
			<div class="row hidden-xs hidden-sm">
				<div class="col-md-4">
																<a href="https://beachmetro.com/" rel="home" class="site-logo"><img src="https://beachmetro.com/wp-content/uploads/2015/10/Logo230x1802.png" title="Beach Metro Community News"></a>
									</div>
								<div id="header-widgets" class="col-md-8"><aside id="oio-widget-2" class="widget oio"><style type="text/css">
#oio-banner-1 { max-width: 728px !important; margin: 0 auto !important; }
#oio-banner-1 .oio-slot { width: 100% !important; margin: 0% 0% 0% 0% !important; padding-bottom: 12.362% !important; }
#oio-banner-1 .oio-last-col { margin-right: 0 !important; }
#oio-banner-1 .oio-last-row { margin-bottom: 0 !important; }
</style>
<ul class="oio-banner-zone" id="oio-banner-1">
<li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" target="_blank" href="http://www.vautogroup.ca" title="The Vigliatore Auto Group" class="external"><img src="https://beachmetro.com/wp-content/uploads/2016/05/VigliatoreGroup-banner-ad.jpg" width="728" height="90" border="0" alt="The Vigliatore Auto Group" /></a></li>
</ul>
<script>
(function(){for(var a=document.getElementById("oio-banner-1"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="728px"};})();
</script>
</aside><aside id="oio-widget-3" class="widget oio"><style type="text/css">
#oio-banner-2 { max-width: 728px !important; margin: 0 auto !important; }
#oio-banner-2 .oio-slot { width: 100% !important; margin: 0% 0% 0% 0% !important; padding-bottom: 12.362% !important; }
#oio-banner-2 .oio-last-col { margin-right: 0 !important; }
#oio-banner-2 .oio-last-row { margin-bottom: 0 !important; }
</style>
<ul class="oio-banner-zone" id="oio-banner-2">
<li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" target="_blank" href="https://inthe6ixrealestate.com/Podcast" title="SOLD IN THE 6IX PODCAST" class="external"><img src="https://beachmetro.com/wp-content/uploads/2021/02/desmond-brown.png" width="728" height="90" border="0" alt="SOLD IN THE 6IX PODCAST" /></a></li>
</ul>
<script>
(function(){for(var a=document.getElementById("oio-banner-2"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="728px"};})();
</script>
</aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><div align="center" style="font-style:italic;padding-top:35px;">A non-profit newspaper serving the Beach, Beach Hill, Birch Cliff, Cliffside,<br>Crescent Town, East Danforth, Gerrard India Bazaar, Leslieville, and Upper Beach since 1972.</div></div>
		</aside></div>
							</div>
			
						<div class="navigation-wrap under-navigation-activated">
								<nav id="masthead" class="navbar navbar-default site-navigation" role="banner">
					<div class="navbar-header">
												<button class="navbar-toggle" data-toggle="collapse" data-target=".main-navigation"><i class="fa fa-bars"></i></button>
												<a href="https://beachmetro.com/" rel="home" class="site-brand navbar-brand visible-xs visible-sm">
																						<img src="https://www.beachmetro.com/wp-content/uploads/2015/10/Logo100x50.png" title="Beach Metro Community News">
													</a>
													<button class="search-toggle visible-xs visible-sm" data-toggle="collapse" data-target=".under-navigation"><i class="fa fa-search"></i></button>
											</div>

					
					
					
					<div id="site-navigation" class="collapse navbar-collapse main-navigation" role="navigation">
						<ul id="menu-top-menu" class="nav navbar-nav navbar-left dw-mega-menu-transition-default"><li class="current-post-ancestor active current-post-parent dw-mega-menu-hover item-17676 menu-news"><a  href="https://beachmetro.com/category/news/">News</a></li>
<li class="dw-mega-menu-hover item-346 menu-calendar"><a  href="https://beachmetro.com/top-menu-items/community-calendar/">Calendar</a></li>
<li class="dw-mega-menu-hover item-17679 menu-arts-entertainment"><a  href="https://beachmetro.com/category/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li class="dw-mega-menu-hover item-17680 menu-sports"><a  href="https://beachmetro.com/category/sports/">Sports</a></li>
<li class="current-post-ancestor active current-post-parent dw-mega-menu-hover item-17678 menu-features"><a  href="https://beachmetro.com/category/features/">Features</a>
<ul class="dw-sub-menu">
	<li class="current-post-ancestor active current-post-parent dw-mega-menu-hover item-17808 menu-deja-views"><a  href="https://beachmetro.com/category/features/deja-views/">Deja Views</a></li>
	<li class="dw-mega-menu-hover item-17810 menu-everyone-has-a-story-to-tell"><a  href="https://beachmetro.com/category/features/ehst/">Everyone Has a Story to Tell</a></li>
	<li class="dw-mega-menu-hover item-18493 menu-eye-on-business"><a  href="https://beachmetro.com/category/columns/eye-on-business/">Eye on Business</a></li>
</ul>
</li>
<li class="dw-mega-menu-hover item-17677 menu-columns"><a  href="https://beachmetro.com/category/columns/">Columns</a>
<ul class="dw-sub-menu">
	<li class="dw-mega-menu-hover item-17701 menu-in-my-opinion"><a  href="https://beachmetro.com/category/columns/in-my-opinion/">In My Opinion</a></li>
	<li class="dw-mega-menu-hover item-18479 menu-beach-memories"><a  href="https://beachmetro.com/category/columns/beach-memories/">Beach Memories</a></li>
	<li class="dw-mega-menu-hover item-17710 menu-the-main-menu"><a  href="https://beachmetro.com/category/columns/the-main-menu/">The Main Menu</a></li>
	<li class="dw-mega-menu-hover item-17695 menu-bottoms-up"><a  href="https://beachmetro.com/category/columns/bottoms-up/">Bottoms Up</a></li>
	<li class="dw-mega-menu-hover item-17708 menu-reel-beach"><a  href="https://beachmetro.com/category/columns/reel-beach/">Reel Beach</a></li>
	<li class="dw-mega-menu-hover item-17704 menu-on-the-wild-side"><a  href="https://beachmetro.com/category/columns/on-the-wild-side/">On The Wild Side</a></li>
	<li class="dw-mega-menu-hover item-17706 menu-pet-of-the-month"><a  href="https://beachmetro.com/category/columns/pet-of-the-month/">Pet of the Month</a></li>
	<li class="dw-mega-menu-hover item-17699 menu-garden-views"><a  href="https://beachmetro.com/category/columns/garden-views/">Garden Views</a></li>
	<li class="dw-mega-menu-hover item-17696 menu-design-and-style-views"><a  href="https://beachmetro.com/category/columns/design-and-style-views/">Design and Style Views</a></li>
	<li class="dw-mega-menu-hover item-24030 menu-east-ender"><a  href="https://beachmetro.com/category/columns/east-ender/">East Ender</a></li>
	<li class="dw-mega-menu-hover item-17697 menu-environment-views"><a  href="https://beachmetro.com/category/columns/environment-views/">Environment Views</a></li>
	<li class="dw-mega-menu-hover item-17700 menu-horticultural-matters"><a  href="https://beachmetro.com/category/columns/horticultural-matters/">Horticultural Matters</a></li>
	<li class="dw-mega-menu-hover item-18490 menu-legal-matters"><a  href="https://beachmetro.com/category/columns/legal-matters/">Legal Matters</a></li>
	<li class="dw-mega-menu-hover item-18491 menu-nutrition-matters"><a  href="https://beachmetro.com/category/columns/nutrition-matters/">Nutrition Matters</a></li>
	<li class="dw-mega-menu-hover item-17703 menu-on-the-child-side"><a  href="https://beachmetro.com/category/columns/on-the-child-side/">On The Child Side</a></li>
	<li class="dw-mega-menu-hover item-17705 menu-open-doors"><a  href="https://beachmetro.com/category/columns/open-doors/">Open Doors</a></li>
	<li class="dw-mega-menu-hover item-17707 menu-real-estate-matters"><a  href="https://beachmetro.com/category/columns/real-estate-matters/">Real Estate Matters</a></li>
	<li class="dw-mega-menu-hover item-18492 menu-veterinary-views"><a  href="https://beachmetro.com/category/columns/veterinary-views/">Veterinary Views</a></li>
	<li class="dw-mega-menu-hover item-18481 menu-archived-columns"><a  href="https://beachmetro.com/category/columns/archived-columns/">Archived columns</a>
	<ul class="dw-sub-menu">
		<li class="dw-mega-menu-hover item-18482 menu-a-childs-world"><a  href="https://beachmetro.com/category/columns/archived-columns/a-childs-world/">A Child&#8217;s World</a></li>
		<li class="dw-mega-menu-hover item-18483 menu-glenn-cochranes-corner"><a  href="https://beachmetro.com/category/columns/archived-columns/glenn-cochranes-corner/">Glenn Cochrane&#8217;s Corner</a></li>
		<li class="dw-mega-menu-hover item-18484 menu-money-life-and-law"><a  href="https://beachmetro.com/category/columns/archived-columns/money-life-and-law/">Money, Life and Law</a></li>
		<li class="dw-mega-menu-hover item-18486 menu-school-views"><a  href="https://beachmetro.com/category/columns/archived-columns/school-views/">School Views</a></li>
		<li class="dw-mega-menu-hover item-18485 menu-school-daze"><a  href="https://beachmetro.com/category/columns/archived-columns/school-daze/">School Daze</a></li>
		<li class="dw-mega-menu-hover item-18487 menu-welcome-at-home"><a  href="https://beachmetro.com/category/columns/archived-columns/welcome-at-home/">Welcome at Home</a></li>
		<li class="dw-mega-menu-hover item-18488 menu-where-are-they-now"><a  href="https://beachmetro.com/category/columns/archived-columns/where-are-they-now/">Where Are They Now?</a></li>
		<li class="dw-mega-menu-hover item-18489 menu-write-on-health"><a  href="https://beachmetro.com/category/columns/archived-columns/write-on-health/">Write on Health</a></li>
	</ul>
</li>
</ul>
</li>
<li class="dw-mega-menu-hover item-17846 menu-letters"><a  href="https://beachmetro.com/category/letters/">Letters</a></li>
<li class="dw-mega-menu-hover item-347 menu-directory"><a  href="https://beachmetro.com/top-menu-items/professional-directory/">Directory</a></li>
<li class="dw-mega-menu-hover item-348 menu-classifieds"><a  href="https://beachmetro.com/top-menu-items/classifieds/">Classifieds</a></li>
</ul>						<div class="hidden-xs hidden-sm">		<ul class="nav navbar-nav navbar-right">
						<li class="rss"><a href="https://beachmetro.com/feed/"><i class="fa fa-rss"></i></a></li>
		</ul>
	</div>
					</div>
				</nav>
				
								<div class="under-navigation hidden-xs hidden-sm">
					<div class="row">
						<div class="col-md-9 hidden-xs hidden-sm">		<aside id="news-ticker-4" class="widget dw_focus_widget_news_ticker">		<h2 class="widget-title">Trending Now</h2>		<div class="news-ticker-wrap headlines" data-interval="4000">
			<ul>
							<li>
					<a href="https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/">Deja Views: A look back at Greenwood Raceway in 1988</a>
									<span class="post-date">April 25, 2021</span>
								</li>
							<li>
					<a href="https://beachmetro.com/2021/04/24/virtual-vaccine-town-hall-meeting-to-be-hosted-by-scarborough-southwest-councillor-gary-crawford/">Virtual Vaccine Town Hall meeting to be hosted by Scarborough Southwest Councillor Gary Crawford</a>
									<span class="post-date">April 24, 2021</span>
								</li>
							<li>
					<a href="https://beachmetro.com/2021/04/24/local-author-erin-ledrews-mindful-me-goes-to-sleep-helps-youngsters-build-coping-skills/">Local author Erin LeDrew&#8217;s Mindful Me Goes to Sleep helps youngsters build coping skills</a>
									<span class="post-date">April 24, 2021</span>
								</li>
							<li>
					<a href="https://beachmetro.com/2021/04/23/man-35-charged-in-connection-with-alleged-home-invasion-in-east-york/">Man, 35, charged in connection with alleged home invasion in East York</a>
									<span class="post-date">April 23, 2021</span>
								</li>
							<li>
					<a href="https://beachmetro.com/2021/04/23/in-my-opinion-with-home-reno-boom-mediation-is-a-good-way-to-resolve-disputes/">In My Opinion: With home reno boom, mediation is a good way to resolve disputes</a>
									<span class="post-date">April 23, 2021</span>
								</li>
						</ul>
		</div>
		</aside>		</div>
						<div class="col-md-3"><form method="get" id="searchform" action="https://beachmetro.com/">
	<input type="text" name="s" id="s" class="form-control" value="" placeholder="Search">
	<input type="submit" class="search-submit">
</form>
</div>
					</div>
				</div>
				<!--top ad here-->
			</div>
		</div>
	</header>

	<div id="content" class="site-content">
<div class="container">
	<div class="content-inner">
		<div class="row">
			<div class="col-lg-9">
				<div id="primary" class="content-area">
					<main id="main" class="site-main" role="main">
											
												
	<article id="post-40907" class="post-40907 post type-post status-publish format-standard has-post-thumbnail hentry category-deja-views category-features category-news">
		<header class="entry-header">
			<h1 class="entry-title">Deja Views: A look back at Greenwood Raceway in 1988</h1>
			<div class="entry-meta">
				<span class="posted-on"><i class="fa fa-clock-o"></i> <a href="https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/" rel="bookmark"><span class="entry-date published">April 25, 2021</span><span class="updated sr-only">April 23, 2021</span></a></span><span class="byline"> <i class="fa fa-user"></i> <span class="author vcard"></span></span></span>
			</div>
		</header>

		

	<div class="row">
		<div class="entry-content col-md-9 col-md-push-3">
							<div class="entry-thumbnail"><img width="648" height="424" src="https://beachmetro.com/wp-content/uploads/2021/04/web-Deja-Views-woodbine1988.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="https://beachmetro.com/wp-content/uploads/2021/04/web-Deja-Views-woodbine1988.jpg 648w, https://beachmetro.com/wp-content/uploads/2021/04/web-Deja-Views-woodbine1988-300x196.jpg 300w, https://beachmetro.com/wp-content/uploads/2021/04/web-Deja-Views-woodbine1988-230x150.jpg 230w" sizes="(max-width: 648px) 100vw, 648px" /><div class="ccfic"><span class="ccfic-text">John Leslie Harrison took the photo above of Greenwood Raceway in 1988. Inset photo shows the same location today with houses.</span></div></div>
						<div id="socialButtonOnPage" class="leftSocialButtonOnPage"><div class="csbwfs-sbutton-post"><div id="fb-p" class="csbwfs-fb"><a href="javascript:"  onclick="window.open('//www.facebook.com/sharer/sharer.php?u=https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/','Facebook','width=800,height=300');return false;"
   target="_blank" title="Share On Facebook"  style="background:#ffffff;"><i class="csbwfs_facebook"></i></a></div></div><div class="csbwfs-sbutton-post"><div id="tw-p" class="csbwfs-tw"><a href="javascript:" onclick="window.open('//twitter.com/share?url=https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/&text=Deja%20Views%3A%20A%20look%20back%20at%20Greenwood%20Raceway%20in%201988&nbsp;&nbsp;', '_blank', 'width=800,height=300')" title="Share On Twitter"  style="background:#ffffff;"><i class="csbwfs_twitter"></i></a></div></div><div class="csbwfs-sbutton-post"><div id="re-p" class="csbwfs-re"><a onclick="window.open('//reddit.com/submit?url=https://beachmetro.com/2021/04/25/deja-views-a-look-back-at-greenwood-raceway-in-1988/&amp;title=Deja%20Views%3A%20A%20look%20back%20at%20Greenwood%20Raceway%20in%201988','Reddit','toolbar=0,status=0,width=1000,height=800');" href="javascript:void(0);" title="Share On Reddit"  style="background:#ffffff;"><i class="csbwfs_reddit"></i></a></div></div></div><p>By DAVID VAN DYKE</p>
<p>Recently, my son Michael and I spent an hour walking around Woodbine Park looking for the two trees depicted in the photo above. Really, how much does a tree grow in just more than 32 years?</p>
<p>The tree on the right had been felled and we did find its stump to know we were in the exact same place John Leslie Harrison was when he took the photo image (above) of Greenwood Raceway in 1988.</p>
<p><img loading="lazy" class="alignnone size-medium wp-image-40909 alignleft" src="http://beachmetro.com/wp-content/uploads/2021/04/web-DejaView-pleasantville2021-300x196.jpg" alt="" width="300" height="196" srcset="https://beachmetro.com/wp-content/uploads/2021/04/web-DejaView-pleasantville2021-300x196.jpg 300w, https://beachmetro.com/wp-content/uploads/2021/04/web-DejaView-pleasantville2021-230x150.jpg 230w, https://beachmetro.com/wp-content/uploads/2021/04/web-DejaView-pleasantville2021.jpg 648w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>His daughter Laura Harrison told me her father walked three kilometres a day and often took his camera with him (a habit I cannot help but agree with).</p>
<p>A tree has been planted in his memory at Woodbine Park near the children’s play area.</p>
<p>Thank you Laura for taking time to drop off these amazing photos you dad took of the race track before it was razed.</p>
<p>Do you, like Laura, have old photographs your parents took of the Beach of yesteryear? Please contact me gdvandyke61@gmail.com</p>
<a target="_blank" href="https://drpeterscode.com/bad-bot-exterminator-protects-wordpress-sites-from-hackers-cyber-ddos-dos-attacks.php" class="external" rel="nofollow"><img src="https://beachmetro.com/wp-content/plugins/dpabottomofpostpage/apixel1x1.jpg" ></a><table></table>						</div>
			<div class="entry-sidebar col-md-3 col-md-pull-9">
								
			</div>
		</div>


	</article>
												
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://beachmetro.com/2021/04/24/virtual-vaccine-town-hall-meeting-to-be-hosted-by-scarborough-southwest-councillor-gary-crawford/" rel="prev">Virtual Vaccine Town Hall meeting to be hosted by Scarborough Southwest Councillor Gary Crawford</a></div></div>
	</nav>																</main>
				</div>
			</div>
			<div class="col-lg-3">
				
<div id="secondary" class="widget-area" role="complementary">
	<aside id="recent-comments-5" class="widget widget_recent_comments"><h2 class="widget-title">WHAT PEOPLE ARE SAYING</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Jen Boyd</span> on <a href="https://beachmetro.com/2012/04/17/walk-storied-lee-avenue/#comment-479311">A walk through the storied past of Lee Avenue</a></li><li class="recentcomments"><span class="comment-author-link">Shelley Dubros (nee Fallows)</span> on <a href="https://beachmetro.com/2012/04/17/walk-storied-lee-avenue/#comment-479309">A walk through the storied past of Lee Avenue</a></li><li class="recentcomments"><span class="comment-author-link">Brian Weller</span> on <a href="https://beachmetro.com/2012/04/17/walk-storied-lee-avenue/#comment-479282">A walk through the storied past of Lee Avenue</a></li><li class="recentcomments"><span class="comment-author-link">Brian Weller</span> on <a href="https://beachmetro.com/2012/04/17/walk-storied-lee-avenue/#comment-479281">A walk through the storied past of Lee Avenue</a></li><li class="recentcomments"><span class="comment-author-link">Ron Messer</span> on <a href="https://beachmetro.com/2012/04/17/walk-storied-lee-avenue/#comment-479279">A walk through the storied past of Lee Avenue</a></li></ul></aside></div>
			</div>
		</div>
	</div>
</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="container">
			<div class="footer-navigation"></div>
<div id="footer-widgets" class="widget-area" role="complementary">
	<div class="row">
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-7" class="widget widget_nav_menu"><ul id="menu-bottom-left" class="menu dw-mega-menu-transition-default"><li class="dw-mega-menu-hover item-379 menu-become-a-volunteer"><a  href="https://beachmetro.com/bottom-left-items/become-a-volunteer/">Become a Volunteer</a></li>
<li class="dw-mega-menu-hover item-380 menu-frequently-asked-questions"><a  href="https://beachmetro.com/bottom-left-items/faq/">Frequently Asked Questions</a></li>
<li class="dw-mega-menu-hover item-381 menu-contact-us"><a  href="https://beachmetro.com/bottom-left-items/contact-us/">Contact Us</a></li>
<li class="dw-mega-menu-hover item-382 menu-about-us"><a  href="https://beachmetro.com/bottom-left-items/about-us/">About Us</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-8" class="widget widget_nav_menu"><ul id="menu-bottom-middle" class="menu dw-mega-menu-transition-default"><li class="dw-mega-menu-hover item-28271 menu-media-kits"><a  href="https://beachmetro.com/media-kit/">MEDIA KITS</a></li>
<li class="dw-mega-menu-hover item-400 menu-distribution-map"><a  href="https://beachmetro.com/bottom-middle-items/distribution-map/">Distribution Map</a></li>
<li class="dw-mega-menu-hover item-401 menu-2021-publication-schedule"><a  href="https://beachmetro.com/bottom-middle-items/publication-schedule/">2021 Publication Schedule</a></li>
<li class="dw-mega-menu-hover item-402 menu-advertising-rates"><a  href="https://beachmetro.com/bottom-middle-items/advertising-rates/">Advertising Rates</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-9" class="widget widget_nav_menu"><ul id="menu-bottom-right" class="menu dw-mega-menu-transition-default"><li class="dw-mega-menu-hover item-24732 menu-voluntary-subscription"><a  href="https://beachmetro.com/subscribe/">VOLUNTARY SUBSCRIPTION</a></li>
<li class="dw-mega-menu-hover item-24736 menu-manage-subscription"><a  href="https://beachmetro.com/manage-subscription/">Manage Subscription</a></li>
<li class="dw-mega-menu-hover item-18114 menu-careers"><a  href="https://beachmetro.com/careers/">Careers</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-md-4 col-lg-offset-0 col-md-offset-2 col-sm-5 col-sm-offset-1"></div>
	</div>
</div>
			<div class="row">
				<div class="site-info col-md-6">
					Copyright &copy; 2021 by <br><a href="https://beachmetro.com" rel="designer">Beach Metro Community News</a>.					<br>
				</div>

			</div>
		</div>
	</footer>
</div>

<style type="text/css">a { color: #487db6}
a:hover, a:active { color: #ba534a}
body { background: url() #474747 repeat top center scroll}
.site-header { background: url()  repeat top center scroll}
.site-footer { color: #555555}
.site-footer a { color: #777777}
.site-footer a:hover, .site-footer a:active { color: #ffffff}
.site-footer #footer-widgets .widget-title { color: #ffffff}
.site-footer .footer-navigation, #footer-widgets { border-color: #a8a8a8}
#footer-widgets .widget_nav_menu:after { background-color: #a8a8a8}
 .site-footer { background: url() #01202b repeat top center scroll}
body { color:#333333; font-family:Roboto Slab, serif; font-size:14px; }
h1 { color:#333333; font-family:Oswald, sans-serif; font-size:36px; }
h2 { color:#333333; font-family:Oswald, sans-serif; font-size:30px; }
h3 { color:#333333; font-family:Oswald, sans-serif; font-size:30px; }
h4 { color:#333333; font-family:Oswald, sans-serif; font-size:18px; }
h5 { color:#333333; font-family:Oswald, sans-serif; font-size:14px; }
h6 { color:#333333; font-family:PT Sans, sans-serif; font-size:12px; }
</style><script type='text/javascript' src='https://beachmetro.com/wp-content/plugins/dw-mega-menu/assets/js/dw-megamenu.js?ver=5.7.1' id='dw-megamenu-front-end-js-js'></script>
<script type='text/javascript' id='dw-focus-script-js-extra'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/beachmetro.com\/wp-admin\/admin-ajax.php"};
var sharrre = {"sharrre_url":"https:\/\/beachmetro.com\/wp-content\/themes\/dw-focus\/inc\/sharrre.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://beachmetro.com/wp-content/themes/dw-focus/assets/js/dw-focus.min.js?ver=1.2.6' id='dw-focus-script-js'></script>
<script type='text/javascript' src='https://beachmetro.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script src='https://stats.wp.com/e-202116.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'143094703',post:'40907',tz:'-4',srv:'beachmetro.com'} ]);
	_stq.push([ 'clickTrackerInit', '143094703', '40907' ]);
</script>

</body>
</html>
